Jumat, 11 Mei 2012

How to Fix Depends: libgtk2.0-0 (>= 2.24.10) but 2.24.6-0ubuntu5linuxmint1 while install GIMP on Linux Mint



Error :
The following packages have unmet dependencies:
 gimp : Depends: libgimp2.0 (>= 2.8.0-1ubuntu0ppa3~oneiric) but it is not going to be installed
        Depends: libgimp2.0 (<= 2.8.0-z) but it is not going to be installed
        Depends: libgtk2.0-0 (>= 2.24.10) but 2.24.6-0ubuntu5linuxmint1 is to be installed
E: Unable to correct problems, you have held broken packages.


How to Fix it :
1. Remove your previous GIMP PPA
sudo add-apt-repository --remove ppa:otto-kesselgulasch/gimp
2. sudo apt-get update


3. Uninstall previous GIMP
apt-get remove gimp


4. Install GIMP
sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp


5.If you want to upgrade it to version 2.8
sudo apt-get dist-upgrade

Tidak ada komentar:

Poskan Komentar